IMAGES ARE STILL MALFUNCTIONING

Get community help here, post test messages, suggestions etc. I will also document here changes that take place such as maintenance and upgrades.

Moderators: Harold_V, Marty_Escarcega

Post Reply
User avatar
BigDumbDinosaur
Posts: 633
Joined: Tue Jun 28, 2011 9:19 pm
Location: Midwestern United States

IMAGES ARE STILL MALFUNCTIONING

Post by BigDumbDinosaur » Thu Nov 03, 2016 1:18 pm

The software running this board has been somewhat obstreperous as of late with image management, something with which the SYSOPs are aware. This post is a test of some image uploads. I'd like to be able to resume updating my F7 build log but won't be able to do so if I am not able to post satisfactory images.

All uploaded files were generated from a monochrome GIF87A image, originally 4608 × 2466 × 2, and reduced to a 1024 x 548 uploaded image size.

—————————————————————————————

The first upload I attempted was a reduced copy of the GIF source file. The upload failed with the error "Image file type mismatch: expected extension jpg but extension gif given." This error has been consistently occurring ever since the board software was upgraded. Of the three on-line forums in which I participate that run on PHP-BB software, this one is the only one that has a problem with GIFs. The other boards run an older version of PHP-BB, making me suspect the upgrade introduce some inadvertent bugs.

The second upload test was a JPEG.
bidir_block_diagram_reduced.jpg
1024 x 548 Monochrome JPEG Image
The upload completed but when I viewed the image during preview of my message the board presented it at the size 548 x 293, not at the uploaded size of 1024 x 548. The board is reporting the image's file size at 40KB, which is also wrong—the file that was uploaded is 139KB. In other words, PHP-BB truncated the file during storage. Aside from size being wrong, JPEG is not a good format for storing monochrome images or images with eight bit color, as the resulting file is bulky despite no or little color information being present. Also, compression in JPEG is "lossy," causing degradation of image quality. It is for these reasons I usually upload GIFs to public forums, even though GIF color rendition is not as fine as some other image formats.

The third upload test was a PNG.
bidir_block_diagram_reduced.png
1024 x 548 Monochrome PNG Image
As can be seen, that upload was successful as well. However, going from GIF to PNG caused a substantial degradation of image quality. PNG was originally developed as a way to get around the LZW compression algorithm patents that encumbered GIFs. Those patents expired in 2004, so there is no particular reason to use PNG, other than its higher color resolution.

The final upload test was a TIFF. It turns out Chaski doesn't accept TIFFs.

* * *
Science makes it known. Engineering makes it work.

User avatar
SteveHGraham
Posts: 6975
Joined: Sat Jan 17, 2009 7:55 pm
Location: Florida

Re: IMAGES ARE STILL MALFUNCTIONING

Post by SteveHGraham » Thu Nov 03, 2016 4:49 pm

See? Why do people always say I'm crazy instead of instantly believing whatever I say?
Every hard-fried egg began life sunny-side up.

Harold_V
Posts: 17012
Joined: Fri Dec 20, 2002 11:02 pm
Location: Onalaska, WA USA

Re: IMAGES ARE STILL MALFUNCTIONING

Post by Harold_V » Fri Nov 04, 2016 1:40 am

Chuckle!
Well, maybe it's because you're crazy!! :P :P :P

Ok, guys, seriously, Mike is now aware of the problem and thinks he has a solution. He's also spread thin, so he can't address the issue right away. Says he'll get to it about Thanksgiving time, at which time he'll also upgrade the board software once again. Please be patient, and don't lose sight of the fact that this board is provided free to viewers. It provides far more than the vast majority of readers pay in return, keeping in mind that some very generous readers stepped up to the plate when called upon to do so, so the board could be moved to much faster service. We thank those who so generously gave.

Harold
Wise people talk because they have something to say. Fools talk because they have to say something.

User avatar
BigDumbDinosaur
Posts: 633
Joined: Tue Jun 28, 2011 9:19 pm
Location: Midwestern United States

Re: IMAGES ARE STILL MALFUNCTIONING

Post by BigDumbDinosaur » Fri Nov 04, 2016 11:17 pm

More testing. Here's a new error message from the PHP-BB software:
  • The image must be at least 0 pixels wide, 0 pixels high and at most 2048 pixels wide and 2048 pixels high. The submitted image is 2156 pixels wide and 2048 pixels high.
That, my friends, is an outright bug in this board's software. The JPEG image I attempted to upload is exactly 2048 × 1945 pixels, as reported in both ACDSee Photo Manager and Adobe Photoshop (see below screen capture). If anyone has any doubts about this please PM me with your E-mail address and I'll send you the file in question so you can try it yourself.
image_in_photoshop.JPG
Photoshop Screen Capture
Science makes it known. Engineering makes it work.

Post Reply