Anilam Crusader M 3 Axis Mill will not boot up.

This forum is dedicated to those Hobbyists Interested in CNC machining in their home shops. (Digital Read Outs are also topical, as is CAD/CAM as it relates to CNC)

Moderator: Harold_V

Post Reply
sierevello
Posts: 92
Joined: Sat Feb 01, 2003 3:24 am

Anilam Crusader M 3 Axis Mill will not boot up.

Post by sierevello » Sun Oct 21, 2018 2:50 pm

I was hoping to get some help and get my old Anilam Crusader M 3 axis mill up and running again.

It started not booting up on and off and the keypad would freeze and the screen would go blank every few times I would go to use it.

I took all the boards out and cleaned them with deoxit contact cleaner and re-seated them well.

After that it ran fine for an hour and then locked up again and now will not boot up at all.

There is no "click" from the relay when the machine is turned on and on the orange tabbed board there are four red LED's lit up. There is also a red LED lit up on the power supply. I checked across the large blue cap in the cabinet and only got 87 volts DC.

Any idea what the problem could be and what I need to fix it?

Pictures are attached of LEDs and power supply model number.

Jerry at Anilam has retired. So that resource is gone.

Thank You,
Steve
Attachments
IMG_3051.jpg
IMG_3050.jpg

choprboy
Posts: 205
Joined: Sat Oct 29, 2011 11:23 pm

Re: Anilam Crusader M 3 Axis Mill will not boot up.

Post by choprboy » Sun Oct 21, 2018 11:40 pm

No idea and a quick search shows lots of similar issues and not much debug information. It sounds like a power supply problem. Probably best to start with standard electronics debugging and identify/measure all of the individual power rails on each board.

User avatar
NP317
Posts: 1439
Joined: Tue Jun 24, 2014 2:57 pm
Location: Northern Oregon

Re: Anilam Crusader M 3 Axis Mill will not boot up.

Post by NP317 » Mon Oct 22, 2018 12:34 am

That first photo shows a device marked "U C".
That looks like an old rectifier. The type that might become leaky with time and use.
Worth checking out, as it could cause the power supply to output too low a Voltage.
Just my initial thoughts.
~RN

sierevello
Posts: 92
Joined: Sat Feb 01, 2003 3:24 am

Re: Anilam Crusader M 3 Axis Mill will not boot up.

Post by sierevello » Tue Oct 23, 2018 10:32 am

I got in touch with Jerry who used to work for Anilam and he had me check and re-seat all of the IC's on the boards and the old girl fired right back up.

Post Reply