Water pump

This forum is dedicated to the Live Steam Hobbyist Community.

Moderators: Harold_V, WJH, cbrew

Post Reply
hkcarbine
Posts: 69
Joined: Wed Mar 10, 2010 4:27 pm
Location: Las Vegas, Nevada

Water pump

Post by hkcarbine » Sun Oct 07, 2012 12:54 pm

I built a water pump to supply my boiler. Stationary engine. PM Research horizontal, the big one. Pump body brass, plunger stainless with o ring. works great spits water a long way. Anyway, I have been running engine on air to check pump operation. Now no output from pump. Checked and replaced o ring, still no output.. I made my own check valves using chrome plated balls and steel springs. Took valves apart and discovered chrome balls had acquired a carbon like deposit, not easily removed. Finally, to the question. Would stainless balls eliminate problem? Springs had no real deposit, but I will replace with stainless springs anyway. Water is from tap which is softened. Suggestions are appreciated.

Thank You,
HKcarbine

AKA Roger Q

User avatar
RichD
Posts: 292
Joined: Thu Jan 09, 2003 11:16 pm
Location: Canton, Ga
Contact:

Re: Water pump

Post by RichD » Sun Oct 07, 2012 2:22 pm

Roger,
The "norm" is stainless balls and light stainless springs.
If the valves are vertical no springs needed for water service.
Burnish the ball seats for a perfect seal.
Assumming the design is correct, it should work well.
RichD
Happy Rails !
RichD
Colorado Midland Ry Ten Wheeler U/C
Kerr Stuart Wren NG 0-4-0 U/C
www.csppry.org
Imagination is your best tool.

User avatar
tburzio
Posts: 656
Joined: Mon Aug 18, 2008 5:35 pm
Location: San Diego

Re: Water pump

Post by tburzio » Sun Oct 07, 2012 5:50 pm

hkcarbine wrote:discovered chrome balls had acquired a carbon like deposit, not easily removed
I'm gonna bet that's magnesium. My ball bearing pumps get stuck all the time. A few very light taps with the small rock hammer fixes the problem. Tap tap tap rattle, fixed! This is why you should always test your pumps as you are leaving the steaming bay.

Post Reply